Rename `Eql` to `CanEqual`?

Copied from issue since it is SIP material.

Eql is a typeclass used in multi-versal equality to check that regular universal equality == is allowed. I believe that CanEqual is a better name. That way, we do not raise the expectation that this is some sort of equality typeclass.