yield now has meaning only immediately after for loop and therefore can be made a soft keyword.
This will help authors of async libraries, which now need to search for synonyms.
On another side I understand, that reading a dictionary and enriching vocabulary is a good thing, so maybe this change is a bit controversial
It would also make integration with other (JMV-)languages simpler. Project Loom for instance has a
yield() method on its Continuation class.