Change the name for scala.util.Not to scala.util.NotGiven

Scala 3 introduced scala.util.Not which is a very nifty way to know if a given doesn’t exist in the current scope.

With the new design for givens, a better name for this would be scala.util.NotGiven.

This a a thread to discuss and get feedback from the community.

A pull request is currently open:


I think NotGiven is a good name. Not is very short and quite generic. It could mean many things. So :+1: