Personal opinion: of the proposals so far, I strongly prefer the instance ... of
syntax. It reads well and naturally, and gets the point across.
To the similarity with the OO concept of “instance”: this is why I like this option so much. When I teach typeclasses – typically to a crowd that are at least somewhat familiar with OO – I introduce them as the FP equivalent of an interface. And the next step is to teach “typeclass instances”, which I phrase that way precisely because they are closely cognate to the notion of instantiating an interface. So I actually support this choice of wording because, rather than being ambiguous, it supports folks’ learning how to use typeclasses, and helps make them more familiar and less scary.
On the subject of _
: I agree with @soronpo and @julienrf above. IMO, not just allowing but requiring the use of _
when declaring an anonymous instance is consistent with the way names work elsewhere in the language. When I’m declaring a parameter list, and want to say “I have this unnamed parameter”, I don’t omit the name, I replace it with _
. I generally teach _
as being pronounced “whatever”, and this would be entirely in line with that.
I agree that the symbol gets overused, and could stand to be replaced in several places – in particular, I think the language would be improved if:
import com.mypackage._
was replaced with:
import com.mypackage.*
That would be both more in line with other languages (in fact, I still reflexively pronounce it as “star” in this context), and would reduce the mental overhead of _
. OTOH, this usage of _
would still be appropriate:
import com.mypackage.{Foo => _, *}
That is intentionally “anonymizing” that name from the package, in line with the general usage.
In short: we shouldn’t be afraid of making use of _
. We should, however, be striving to regularize that usage, and I think using it here is totally in line with that goal.